16 bit program on windows 10 apvdd.dell error when starting

Hello Everyone,

How was going on

Let me preface this by saying switching to a different program is not an option right now. I need to get this program working. The vendor has a 64bit compatible version in the works but it’s not coming anytime soon.

A client has an old 16bit program - Interest Rate Risk Monitor from The Baker Group. It won’t run on 64bit computers. When we upgraded the user of this program to Windows 10 we kept them on 64bit so they could use all 8gb of ram on their computer. We opted to install a 32bit version of Windows 10 on a VM (using VLK licensing) and the user remotes into that computer to run the program. Has worked fine for the past few months.

Today the user remotes in and gets this error:

16 bit Windows Subsystem

c:\windows\system32\drivers\vdd\apvdd.dll. An installable Virtual Device Driver failed Dll initialization. Choose ‘Close’ to terminate the application.

Clicking close closes the program. Trying, again and again, results in the same error.

I checked and this apvdd.dll file is not on the computer. The driver’s \vdd folder doesn’t exist either.

I can reboot the computer and perhaps every 10th reboot the program will open without error. Yet the apvdd.dll file and folder still do not exist. If I close the program and try to open it again the error pops up. Reboot a few times and eventually, the program will open up without error. But will not open up again until you reboot a few times.

Tech support feels the problem is not their program and instead is a virtual machine issue - which it very well could be. I am not arguing that point.

if it’s possible. then please solution is necessary.

Thanks a lot in advance

Hello @Charlie

You can check the folowing link to solve the problem.