GPU Column not showing in task manager


I have desktop which has Asus 2GB graphic card. I upgraded this PC from windows 8.1 to windows 10 latest year. When i was working yesterday with the PC i found GPU column not showing in the task manager? Not sure why?

I have few other PCs which doesn’t have a graphic card but it shows GPU column in task manager!!

I am not sure why the PC with Graphic Card not showing the GPU column and the PC without Graphic card showing GPU??

Any guess?

Hi @AnthonyD,

Your chip’s driver must support WDDM version 2.0 or above. If your GPU’s driver doesn’t support WDDM version 2.0 or above, you simply cannot view your GPU performance in the task manager.

If there is no GPU in the Task Manager in Windows 10, try the following.

First, make sure your driver is up to date and you are using windows 10 version 1709 or above.

Check WDDM 2.0 Support

Open the run dialog box via the Win+R keyboard shortcut. Type in Dxdiag.exe and tap the Enter key. If you see a prompt of any sort on you screen, click ‘Yes’ on it.

When the dxdiag tool opens, go to the Display tab. In the Drivers section, look for Driver Model. If it doesn’t say WDDM 2.0, or anything above 2.0, then your driver is not compatible with this new feature.


If your driver has WDDM support as @tjnihal said you can add column from registry editor.
open run window and type regedit and go to this location.
Computer\HKEY_LOCAL_MACHINES\SYSTEM\CurrentControlSet\Control\GraphicsDrivers and make new DWORD(32-bit) Value and name TdrDelay. then right click on this and modify. choose decimal Base and enter 60 in Value data and click OK and check task manager

Hello @AnthonyD

For GPU column your system compatible for WDDM 2.0, if you don’t see it, your system is using older type of driver .
you can check this by using dxdiag command in run menudxdiag

upgrade your graphic driver if you see 1.1

1 Like
  1. Right click on that tab in task manager and Enable GPU

Thanks @tjnihal , @VIkasmadan For the detailed information

Please check the below image you are right, it turned out My PC has older drive. So nothing I can do about it.


Glad it helped…:grinning:

Update your Graphics and Chipset drivers to fix the issue.