Windows 10 Update Failure (0x80070002) Windows 10 1809 to 1903

Hi.

We have more than 40 Computers at our office. but one computer has been updated on Windows 10 1809 to 1903.

For the exception, Microsoft reported postponing the update as it claimed it not yet ready (compatible) for the update since June. Since August, Microsoft informed us that our machine should now be compatible.

We tried several times in vain. we could fix the situation of the first few trials and repeated in vain.
How-to-Fix-Windows-10-System-Restore-Update-Error-Code-0x80070002

Now we got the picture that it starts installing, requires a reboot for 1903, reboots back to 1809 and reporting error code 0x80070002 without any further details.

We repeated this twice and used the SFC and DISM commands, with the same results. On the first trial, SFC and DISM helped, but the result didn’t change the less. In the last trial, we repeated these commands although they couldn’t find anything to fix, even if applied directly before the reboot.

As far as we understood, this error code means that some resource is missing. But we couldn’t see any report WHICH resource Windows 10 1903 considers missing. Any hint where and how to search?

When looking into events, we find the same error message. In a detailed (XML) view of this error message, we got an update GUID and a service GUID. May these help me to identify which part of the update process is missing which resource (and eventually how to get it)?

Hello @VictorV

Follow these steps to solve the problem.