Tech

Cannot turn off Calendar allerts

Every time I turn off alerts on my calendar, it shows up again on the specified date. I use shared calendar with my wife and she has the same problem. Now, I have to put the alert up month in advance or even further since iPhone refuses to simply turn it off. How can I get it fixed?

  1. Open the Settings app.
  2. Tap Notifications .
  3. Tap Calendar .
  4. Tap the green “Allow Notifications” switch. The button should turn grey. Doing this will disable all notifications from your calendar
  1. Open the Google Calendar app
  2. In the top left, tap Menu
  3. At the bottom, tap Settings
  4. Select one of your calendars, like Events .
  5. Tap a notification and choose None . Repeat for each notification.
  6. If you have multiple accounts or calendars, repeat these steps for each calendar.

which IOS version do you have? first update IOS version and check if the problem will appear again

Hello
Please check the link below