Tech

DHCP Issue in the Office

Hello

I have Mikrotik CCR1036-12G-4S router and Cisco Catalyst 2960-X Series Switch in the Office

The Office is on 2 floors. Mikrotik is on the second floor and the switch on the first. The distance between Mikrotik and Cisco is 50-60m.

On the Switch I configured the only SSH, and on Mikrotik I configured the DHCP server.

On the Switch, there are connected PCs, Printers and Scanners.
For this network I got new subnet 192.168.150.0/24

when I finished everything, the devices got IP addresses and work properly, but after 10 minutes the devices lost IP addresses.

I tried to change the lease time, the default time is 1 hour, and I changed it to 10 minutes.
Devices got IP addresses when lease time is starts again, but in some minutes they lost.

On the Devices, when I change DHCP configuration to static, the devices are pinging, but on DHCP they lost IP.

If you have any solution please advise me to fix this problem.

DHCP lease should be at least a week or 2 weeks. There is nothing in your description which suggests it needs to be any more frequent than that.

If you have a frequent DHCP lease renewal policy, that is probably your cause. The device might not be that clever, be able to handle the requests or have an issue with its ARP table.

Looks like you have you tried a manual IP reservation or manual through DHCP. It takes a little bit more management, but works. If you aren’t reserving in DHCP, they won’t show in DHCP. They will show in DNS.

Be sure not to overlap IP ranges.
Reserve separate IP ranges for DHCP, manual reservations, printers, other network devices.

Also in the DHCP server I reserved IP addresses for printers, I made static IPs for each printer mac address, but it also lost IP address.