Tech

Error 0xc004000d on Windows Server 2012

Hello. I can’t install remote desktop services on server 2012. I get an error: “one or several parent features are disabled so the current feature cannot be enabled - error 0xc004000d.” Any suggestions on this?

2 Likes

Hi,

I want to confirm with you if WSE is the only DC on your domain?

Please try to install Bitlocker Drive Encryption feature using external installation medium. Before installation, manually clean existing CBS.log:

  1. Manually delete CBS.log - C:\windows\logs\cbs\cbs.log.

  2. Open server manager – add roles and features – select Bitlocker Drive Encryption feature and click nets – click specify an alternate source path – insert the installation medico and specify the source file location

  3. If it failed, provide me the newly generated CBS.log.

1 Like

Hi @Hudson,

It seems .net feature is not enabled in the server. Best way to enable .net is using the Windows server OS disk or ISO image file after mounting as drive and run the below command in CMD via run as admin
dism /Online /Enable-Feature /FeatureName:NetFX3 /All /Source:D:\Sources\SxS\ /LimitAccess

Replace the drive letter D with your OS drive. If you are still unclear follow this article for step by step installation How to install .NET Framework 3.5 on Windows Server 2012 and Windows Server 2012 R2.

Hope this helps to solve your issue

1 Like

Hello

There are some ways to fix this issue, and I think this will help you

first of all, the reason may be a firewall, so try to install these services without a firewall. and if you get any error about a broken server or “configuration did not complete” you can use this Powershell command

$tss = Get-WmiObject -namespace root\cimv2\terminalservices -class Win32_TerminalServiceSetting
** $tss.SetAllowTSConnections(1,0)**

the second way is this.

As part of the broker connection broker feature install the “Windows Internal DB” is installed along with it’s service. However the Service will not start due to login failure.

I’ve worked around this by:

  1. From another 2012 host run up server manager and add in the relevant servers, (this is because the connection broker I am configuring is on one of the hyper-v hosts that will be rebooted and I want to keep an eye on the install)

  2. Start the RDP install wizard from Add Roles and Features.

  3. Add in all the relevant servers.

  4. Deploy the install.

  5. When the “RD Connection Broker role service” progress bar stalls go to the Services on the connection broker.

  6. A new service will have been installed “Windows Internal DB”, you made need to refresh.

  7. Edit the Logon Properties for this service to be local.

  8. Start the service.

  9. Return to the wizard

The progress bar in the wizard will then start moving again and the installation will complete.

1 Like

To resolve this issue, please follow the below process step by step:

Open an elevated PowerShell prompt and enter the following to check if the .NET Framework Feature is installed:

Get-WindowsFeature Net-Framework-Features

Then enter:

Get-WindowsFeature Net-Framework-Features | Remove-WindowsFeature

Finally repeat the first command to check the feature has been removed:

Get-WindowsFeature Net-Framework-Features

dism /Online /Enable-Feature /FeatureName:NetFX3 /All /Source:D:\Sources\SxS\ /LimitAccess

Here D: is the drive letter of the Windows Server 2016 installation media.

Restart-Computer