Tech

Error while importing the module for exchange online

Got an error while importing the module for exchange online that, in my mind, makes no sense. I have upgraded my PowerShell to latest 5.1.16299.248, and patched up Win2012 r2 KB3191564. The error message goes as following:
“Import-Module : The version of Windows PowerShell on this computer is ‘5.1.14409.1018’. The module ‘C:\Program Files(x86)\WindowsPowerShell\Modules\ExchangeOnlineShell\2.0.1\ExchangeOnlineShell.psd1’ requires a minimum Windows PowerShell version of ‘5.1.16299.248’ to run. Verify that you have the minimum required version of Windows PowerShell installed, and then try again.”

Hi @Ashley,

The version of PowerShell isn’t supported when running “Install-Module -Name ExchangeOnlineShell”

When connecting to Exchange Online, we should import “ExchangeOnlineManagement” rather than “ExchangeOnlineShell” module. Microsoft provides a step by step tutorial about how to connect to Exchange online with PowerShell.

Let me know if this was helpful

Hello
Please follow the below link
https://social.technet.microsoft.com/Forums/exchange/en-US/bd346493-0604-4a48-bcb7-04c8502f5c57/exchangeonline-powerhsell-import-error?forum=onlineservicesexchange