Generic failure on Hiper-V virtual switch manager

Hi, I need help! I got a “Generic failure” when I was trying to create general switch on Hiper-V virtual switch manager. I tried it several times already, nothing exactly works (even reinstalling the whole software). Can I get it fixed somehow?

First thing to check is that the Hyper-V Extensible Virtual Switch is enabled in your NIC’s Properties:
If it’s missing then click the Install button and add it (located under Protocol):
Don’t forget to reboot!


Did you really re-install the whole OS? I guess this was a non-production server if you could do that.
Hyper V is an add-on and can be removed \ added that way, although that won’t fix the issue.

The generic error is Windows saying that it doesn’t really know what went wrong.

I suspect:

  1. Faulty or unsupported network card. A really old NIC could throw up errors and we don’t know the spec or age of your system.
  2. Run an virus check (long shot, but you are flying blind).
  3. Check the Windows event logs for any hardware. or resource issues. Also check disk space.
  4. Have you disabled any Windows services required by Hyper V?

I supect the issue will be obvious when you find it.
I have worked on Virtual server before MS purchased it and rebranded it Hyper V and have seen some crazy stuff.
Feel free to post any logs back here or PM me.