Group Policy not applying for power setting in Windows 10

Can someone please tell me where the Group Policy is to control the following setting:

On battery power, stay connected to Wi-Fi while asleep

This is for a tablet running Windows 10 Enterprise version 1703. I have installed the appropriate Group Policy ADMX templates for Windows 10 version 1709 into my AD central store but still can’t find the option.

Here’s the screen in question (Settings, System, Power & Sleep):

I have been through all the documents available online but still cannot find the relevant information. The closest solution would have been the registry change but that’s almost impossible to deploy using GPO as the NIC GUID will be different for every device.

I have not seen this particular option on previous versions of Windows and I’m not sure the Microsoft GPO team has caught up with all the new Windows 10 tablet features yet.

Any suggestions or links will be great.

Thank & Regard,

In your case, please ensure that you create and edit GPOs which will be applying to Windows 10 machines only from a system which is also running Windows 10. Otherwise you may see this kind of sympton. Also, be sure that the Windows 10 machines actually reside in an OU to which the Windows 10 policy is linked and that the Windows 10 policy itself is enabled. You may also run the command below on the Windows 10 machines to see why the policy is not applying and then take corrective action from there:

gpresult.exe /H gp_report.html

Refer to this article for more guidance if the above steps do not help: 10 Common Problems Causing Group Policy To Not Apply

And finally try this if the above steps do not help:

  1. Open the Registry Editor on a problematic Windows 10 machine

  2. Navigate to HKLM > SOFTWARE > Microsoft > Windows > CurrentVersion

  3. Delete the “Group Policy” folder

  4. Reboot the machine