How to disable screen lock in Windows 10?

Dear experts,

We have one PC in our office which is mainly used for monitoring other devices in the network. This PC runs 24/7 every day. It was working fine for the last few years, but now it`s started to going on sleep after 15 minutes. All of my colleagues confirm the did change any power setting but this happening indefinitely.

Troubleshooting steps we followed:

  1. Verified and reset the Power Settings
  2. Verified and reset the screensaver settings
  3. Verified and confirm the local group policies
  4. Verified and confirm the registry

But none of them was helpful. Any advice where to look for to disable screen lock after a certain time of inactivity?



Hi @Oliver1,

Try this I hope one of them will be helpful.

  1. Disable the startup items

  2. Disconnect all USB, network, and Bluetooth devices

  3. Uninstall the graphics driver

  4. Disable/Re-Enable hibernate

1 Like

Hi @Oliver1.

Please confirm if the below Group Policy object is enabled or not. If the below policy object is not enabled please enabled and try this solve your problems.

  1. Right-click the Start button.
  2. Click Search .
  3. Type gpedit and hit Enter on your keyboard.
  4. Double-click Administrative Templates .
  5. Double-click Control Panel .
  6. Click Personalization .
  7. Double-click Do not display the lock screen .
  8. Click Enabled .
  9. Click Apply .
  10. Click OK .