Tech

Local Activation permission issue

I am kind of scared of updates at this point. After the newest update, my Win 10 decides to not work anymore and provides me with this error - The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {6B3B8D23-FA8D-40B9-8DBD-B950333E2C52}

What the heck is this now? I never got permission errors before so I have no idea how to approach this one. Can someone help me out?

Hi @Roberts101,

Check if the below steps are helpful

  1. Please type Regedit into Start Menu.

  2. Go to HKEY_Classes_Root\CLSID*CLSID* .

    Note : CLSID stand for the ID that appears in your event viewer error. In your case, it’s {6B3B8D23-FA8D-40B9-8DBD- B950333E2C52} .

  3. Right click on it then select Permission .

  4. Click Advance and change the owner to Administrators . Also click the box that will appear below the owner line.

  5. Click Apply and grant full control to Administrators.

  6. Close the tab then go to HKEY_Local_Machine\Software\Classes\AppID*APPID* .

    Note : AppID is the ID that appears in your event viewer. In your case it’s {4839DDB7-58C2-48F5-8283-E1D1807D0D7D} .

  7. Right click on it then select Permission .

  8. Click Advance and change the owner to Administrators .

  9. Click the box that will appear below the owner line.

  10. Click Apply and grant full control to Administrators.

  11. Close all tabs and go to Control Panel --> Administrative Tools .

  12. Open Component Services .

  13. Click Computer , click My computer , then click DCOM Config .

  14. Look for the corresponding service that appears on the error viewer.

Note : For this step, look for the one that appeared at the right panel of the RegEdit. For example, the AppID {4839DDB7-58C2-48F5-8283-E1D1807D0D7D} registry key contains the " ShellServiceHost " data with a (Default) as a value name. Now look for " ShellServiceHost ".

  1. Right click on it then click Properties.
  2. Click Security tab then click Customize in the Launch and Activation permissions section. Click Edit. Click Add. Add a Local Service . Then Apply.
  3. Tick the Local Activation box.
  1. Download PowerRun - PowerRun v1.1 (Run with highest privileges)
  2. Unzip the file and run PowerRun.exe or PowerRun64.exe
  3. Add Dcom Config by clicking the + Gear Icon
    Location - %SystemRoot%\System32\dcomcnfg.exe
    Working Dir - %SystemRoot%\System32
    Click Apply List
  4. Double Click on the dcomcnfg.exe you just added to open Dcom Config
  5. When in Dcom Config click View > Detail so you know you’re working on the right App ID
  6. Right Click on ShellServiceHost > Properties > Security Tab > Customize > Edit
  7. Add LOCAL SERVICE (if need be) and check Local Launch and Local Activation
  8. Close Dcom Config
  9. Close PowerRun
    10, Reboot PC