Long Path 259 character limit Issue with Windows 10

Hi there,

I am using Windows 10 for last few months now I’m trying to find more information with regards to and enable long path capability.

According to https://www.howtogeek.com/266621/how-to-make-windows-10-accept-file-paths-over-260-characters/, I just need to modify the registry value below:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem] “LongPathsEnabled”=dword:00000001

However, I still can’t get passed the 259 character limit. As a test, I tried to create folder and files with more then 259 characters but still, I am getting the same error.

1 Like


The maximum length for a path (file name and its directory route) — also known as MAX_PATH — has been defined by 260 characters. But with the latest Windows 10 Insider preview, Microsoft is giving users the ability to increase the limit.

The recent most Windows 10 preview is enabling users to change the 260 characters limit. As mentioned in the description, “Enabling NTFS long paths will allow manifested win32 applications and Windows Store applications to access paths beyond the normal 260 char limit per node.”


If you wish to utilize this feature, however, you will be required to make some edits to using Group Policy. Follow the steps below:

  1. Open Group Policy Editor (Press Windows Key and type gpedit.msc and hit Enter key .
  2. Navigate to the following directory: Local Computer Policy > Computer Configuration > Administrative Templates > System > Filesystem > NTFS .
  3. Click Enable NTFS long paths option and enable it

I would ask first Why do you need such long path names?

Even if you manage to use the long path in your files and folders then are not going to have any recovery plans as you may not be able to recover these files even if you managed to have a backup for them? Also shadow copy etc may not work properly.

Your drive needs to be in NTFS format and I have not heard the next steps and ETA after Explorer got read support for long paths. It seems odd there is no announcement since ReFS enables long paths by default. I think you need to use PowerShell even best try to enable using GPO editor as above mentioned by digitalindialimited