Microsoft Store Code: 0x80131500 in Windows 10 version 1909

Microsoft Store Code: 0x80131500


I am using Windows 10 version 1909. I am not sure why I always ended up problems in Windows one resolving another. Now I am not able to load Microsoft Store in my Windows 10:

As you can see in the below image while opening Microsoft Store I am getting the error code 0x80131500. Try that again Page could not be loaded. Please try again later.

I tried to reset the Microsoft Store app in setting panel and even tried to uninstall and reinstall it but nothing worked.

Any help is highly appreciated


1 Like

Hi @Abbey,

Please unselect the deprecated version of TLS in your device and check this resolve your issue. You can uncheck the deprecated version of TLS by following the below methods:

  • Search for “Internet Options”

  • Open the App

  • Select the “Advanced” Tab

  • Scroll to the Bottom of the List where you can see “Use SSL/TLS”

  • UN-Select SSL 3.0 and TLS 1.0 and 1.1

  • SELECT TLS 1.2

  • Click “Apply”

  • Click “OK”

Reboot Computer

Hope this helps.


Thanks nihal.

Let me check and come back to you,


You have already mentioned you reinstall the App but did you reinstall the App alone or all the Windows 10 App package?

Anyhow this is the best practice to reinstall all the Application package using the below command maybe if you are lucky this will solve your issue.

  1. Click windows search bar > type in Windows PowerShell. Right-click PowerShell and select run as administrator. Press yes.

  2. Copy below texts:

Get-AppXPackage -AllUsers -Name Microsoft.WindowsStore | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml” -Verbose}

Right click the white frame > Select edit > Paste above texts > type exit > press Enter

Restart your computer.