Recover system reserve partition?


I had two disk in my PC, recently I installed windows 10 manually installation was successful and everything was working fine till now. Now I bought a new disk to replace the another old one. So, I simply remove the disk and replace the New one but I am getting black screen on BIOS.

So, I insert the old disk again and when I check the disk management I found the old disk has system reserved partition install??

Now I am in trouble I don’t No how to move those partition to my primary OS drive.

Please help

1 Like

Hi @surash.2019,

Welcome to the community! :bouquet:

As you have already found out system reserver partition has ended up in the second drive. Without this hidden partition, your OS will not boot up in the BIOS. In this case Windows Backup or Windows Image recovery will also not helpful. In my opinion, you have two options:

Option 1: Rebuild System partition

There is some article online recommended to rebuild the Rebuild System Partition I am not sure It will be helpful in your case unless you tried it by your self. So, Please follow the below steps to rebuild system partition in your computer.

This will need the assistant of Windows Installation Disc or similar bootable devices to help you enter into WinPE Command Prompt.

  1. Boot up your computer from the Windows Installer. At the step of “Where do you want to install Windows”, press Shift + F10 to bring out Command Prompt.

  2. At the prompt, to create the boot configuration file on a system drive instead of the System Reserved partition, input “bcdboot c:\windows /s c:” without quotes and hit Enter. You’ll see a return message: Boot files successfully created.

  3. At the prompt, input “bootrec /fixmbr” without quotes and hit Enter.

  4. Chances are that you’ll receive this error “Element not found” after the command. Then, you need to make the partition Active, using Diskpart. (If no error message received, skip to step 6.)

  5. To make partition Active, please enter following commands successively.

  • diskpart

  • list disk

  • select disk n (where n is the disk number of the system drive)

  • list partition

  • select part 1

  • active (the correct message should be: DiskPart marked the current partition as active)

  • exit (leave diskpart)

  • Active

  1. Now, input these two commands to rebuild BCD file.
  • bootrec /fixboot

  • bootrec /rebuildbcd

  1. When it asks to add installation to boot, print Y and hit Enter. Then, you may leave Command Prompt and start your computer now.

If you do not have a Windows installation disc, or you are not familiar with command-line operations, you may want to take a look at the second method. It provides a graphical user interface that is suitable for common users, and also command-line operations for advanced users.

Option 2: Reinstall the Windows OS

This is the option I will recommend, even you try to rebuild there is a chance getting into error. If I were in your place I will simply clean install the windows in the existing or new drive. Because this is the best option to consider instead playing with partition recovery.

1 Like


It will be good if you install New OS. Download it from Official site. you can install it on your new disk and then move your files from old to new disk

1 Like

Hello @surash.2019
Welcome to community! :bouquet:

As you mentioned that you had two harddisk in your PC, and you had installed windows 10, you just check that, on which, harddisk you had installed windows 10, reconnect that harddisk and check it.

May be you have installed windows in disk 1 and you are connecting disk 2

If still there is problem then you will have to install windows 10 again

Hey there!
You could rebuild the system or reinstall windows

Hi All and thanks @tjnihal for the detailed explanation.

First I tried to take system image and recovered it in another drive, recover was successful but the OS is not booting up from the new drive not sure why and the diskpart commands looks uneasy for my knowledge. So, as recommended by all I fresh installed the OS and restarted everything again.