Tech

Seagate backup Disc stopped working

Hi all! I have recently upgraded to Catalina 10.15.1 and my Seagate backup Disc stopped working properly. Windows is not recognizing it “disc can’t be found". I tried 2 different disks but none worked so far. How can I get it to connect with PC? It’s MacBook Pro 15.

I found a solution here, just need to show it up on Finder bar

Hey there!
So, do you have USB or network backup drives?

If network, do you still have the network path present for the drive in Finder? If not, it’s easy to re-establish. Before Catalina, I simply used the UNC (which was “NAS”) for my backup drive, with or without a share name. I now have to use the IP address of the drive instead of the UNC. So, the drive-path now looks like “smb://192.168.1.109/backupshare”. After that, I used Finder’s menu bar “GO > Connect to Server” to redefine the path. You will then need to provide user ID and password for the drive volume and/or encryption, if you used it.

Of course, you may already be way out ahead of me and have already tried all this. If so, I wish you luck.

Hello

which OS do you have on your Macbook. is it Windows or MAC OS?