Tech

Setting up a Linux live USB with 18.0

I’m setting up a Linux live USB with 18.04. When I tried to boot I get to grub 2.02. I would be happy to learn how to boot off the live USB again.
Here is what I did so far:
The first boot of the USB was good, plugged into my laptop, and started installing the software. Then on a different laptop, I tried to start up again, it gets me to Grub 2.02. Grub not recovered. Following I used ls and I was able to see three accessible drives. (memdisk)- it contains only grub/grub.conf, (hd0,msdos2)- contains folders and files belonging to casper-rw from previous luve usbs’ (I can’t find any folders to grub or the vmlinuz and initrd).
When I boot up (windows mode) and check on file explorer from USB, I can find casper/wmlinuz,casper/initrd and also boot/grub folder containing grub.conf file and some other files. (hd1,gpt1)- contains an efi folder with Microsoft boot and dell folders, and the other 6 drivers grub won’t read.
What should I do to get the USB to boot again?

Hello
Please check the link below