Tech

The SwiftSupport folder is empty

While trying to publish archive on Appstore Connect, I get an error email from Apple Store Connect that goes as this:

"Dear Developer,

We identified one or more issues with a recent delivery for your app, “Notorioustrade” 1.4 (1). Please correct the following issues, then upload again.

ITMS-90424: Invalid Swift Support - The SwiftSupport folder is empty. Rebuild your app using the current public (GM) version of Xcode and resubmit it.

Best regards,

The App Store Team"

I use Mac Os Mojave and Xcode as well to get the code done. I could really use help on this one…

2 Likes

Hello
Please check the link below

Hi @Godfrey,

You have 3 possible options here:

  1. explain the situation to Apple Connect and ask what you should do to " Rebuild your app using the current public (GM) version of Xcode and resubmit it.", as you are already using the last GM.

  2. wait for next GM

  3. if you have another Mac with XCode installed, try to build and resubmit from there.

Thanks

1 Like

Hello @Godfrey,

This issue comes whenever you have a swift project or you are using a library that built using swift. I am working on chromium open source project for some reason I used a swift library and encounter the same issue on uploading to AppStore. Fix that I did following.

1- Get your .app file

2- Create your folder with “app_name” that must have two folders with name Payload and SwiftSupport

3- Get all swift libraries from this path “/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/lib/swift” related to phones not simulator

4- now create iPA file and upload on the store.

Thanks

1 Like

Hi @Godfrey,

I think you need to deploy an AppStore signed IPA to the AppStore / iTunes Connect / TestFlight!

I saw in some cases the upload of a non-AppStore signed IPA succeeds, but the IPA will eventually be rejected.

What you have to know is that only AppStore signed IPAs can are accepted and can be distributed through App Store / iTunes Connect / TestFlight!

Hi @Godfrey,

https://tech.bobcloud.net/t/the-swiftsupport-folder-is-empty/648/3?u=tjnihal

If my above solutions did help you solve this issue. Please follow the below instruction

First, and probably the simplest solution: Delete Xcode from your machine and go to the app store and reinstall it.

You need to be pushing your project from the most recent app store version of Xcode. If the version on the app store is behind the beta you are using, see if you can still build and run the project in the most recent app store version and push it from there.

Try to use the -exportOptionsPlist tag while building the project in command line with the xcodebuild as the old tags -exportFormat and -exportWithOriginalSigningIdentity appears to no longer be compatible (and were perhaps the defaults). If you are doing this then simply add the Method key to your plist file and set its value equal to app-store then pass it to xcodebuild using the mentioned tag.

Hello

there is some ways to fix this issue and you can try, I hope it will help you

first do this way

  1. Go to build settings and make flag Embedded Content Contains Swift Code -> YES, if your code contains partial swift code or entirely made in Swift

  2. Archive your build using Xcode->Product->Archive

  3. Export the Archive Build you will suddenly see the difference build size will be 40+ MBs this is because XCode has added SwiftSupport folder which was missing

  4. Now upload this build using Application loader

  5. If this does not work check that if you have multiple XCode on your system goto Xcode->Preferences->Location->Command Lines Tools has the same latest or the same Xcode from drop down selected on which you have done the coding & vola it’s done.

if it does’t fix your problem try this way

1- Get your .app file

2- Create your folder with “app_name” that must have two folder with name Payload and SwiftSupport

3- Get all swift libraries from this path “/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/lib/swift” related to phones not simulator

4- now create iPA file and upload on store.

1 Like

What you need to do is change your Always Embed Swift Standard Libraries to YES. It’s not that simple so let me break it down for you:

  1. Open Xcode project/workspace
  2. Go to Build settings
  3. Select basic and levels on the top bar

  1. After changing this you will see all of your projects/targets in your table of content.

  2. Now, look for Always Embed Swift Standard Libraries on your projects/targets and make sure everything is NO apart from your main project/target this needs to be YES.

Now you can re-archive your app before you upload it to Apple I would check the content of the app export as you need to make sure it’s right. When the app has to build Show in finder then cmd + click or right-click from the menu select Show packaged content.

You need to make sure that there is no SwiftSupport folder in the package or if there are there need to be some files in there. If it is empty something is wrong.

1 Like

I have a way to verify that your ipa will be approved or not before submitting it:

  • drag the .ipa file into a new folder (call it analysis)
  • right click the ipa file and rename it to .zip (confirm the dialog to use .zip)
  • double click the zip file

here if you get a folder (with the same name as the .ipa file) that has the following subfolders in it:

  • payload
  • swiftSupport
  • Symbols
    Screenshot_1

hen you are good to go, however if you only see the Payload folder within… then you gotta try again

also a couple of pointers

  • I’ve tried setting “Embedded Content Contains Swift Code” to NO, it worked just once then stopped working after that
  • I’ve ensured that I had no cocoapod errors… that didn’t help either
  • I’ve tried manually adding the SwiftSupport folder inside the archive as suggested here… but then i got all sorts of side effects… didn’t work
1 Like