VPN cannot connect On Windows 10. MacOS/Andriod can (to 2012 r2 L2TP server)

Hi there,

My colleague got a windows 2012 r2 server setup the Past few days ago (inherited) and trying to connect at home with L2TP PSK.

It works immediately with MacOS as well as on his Android phone.

New windows 10 Surface Pro, as well as a Windows 10 Pro Laptop both, cannot connect and give this error:

The L2TP connection attempt failed because the security layer encountered a processing error during initial negotiations with the remote computer.

Here’s what he tried so far:

Adding registry key to enable nat to nat VPN:


RegValue: AssumeUDPEncapsulationContextOnSendRule


Data Value: 2

Made sure the services “IKE key generation module and AuthIP” and “IPSEC policy agent” are enabled

Added firewall rule to allow UDP 500,4500 inbound/outbound

Enabled MS-CHAP v2 in the security tab of the VPN connection

Tried connecting via the control panel vs taskbar

Restarting machine and services.

Uninstalling WAP devices in device mgr and reloading.

he is wondering if the setup on the server-side might be incorrect. at least for what a windows 10 machine might require to connect. he thinks it’s set up right since Android & macOS have no problem but maybe there’s something that only pertains to windows?

Well If anyone has some more ideas they can share us


Hello @Palmer

Would you please share the screen shot of error message.
You can check these setting also.

  1. Make sure the server is online. …
  2. Make sure the password and username are correct. …
  3. Restart the VPN software. …
  4. Clear your device of old VPN software. …
  5. Check the authentication process. …
  6. Check your firewall. …
  7. Use a quality VPN service provider. …
  8. Try using different ports.