Windows 10 1809 upgrade gone wrong. - "System thread exception not handled"

Okay, thinking all the dust had settled with 1809, I foolishly decided to upgrade my i7 3930k desktop to Windows 1809 (I know, I know. No sniggering at the back please ).
Anyway. of course, things went badly and now whilst it will boot occasionally (and when it does it’s 100% rock solid), most attempts at booting will result in a “system thread exception not handled” BSOD.
It happens 2 or 3 seconds after the first set of spinning dots come up. There are no events in the event log and no minidumps so whatever is happening seems to be happening before that is loaded.
It will even occasionally cough up an “IRQL not less or equal” message and will even often happen before windows boots into recovery options
All windows drivers are up to date including GPU and other peripherals I’ve got. Everything in the device manager looks cool. MB BIOS is as up to date as I can get it.
I’ve tried the following.
01 Memtest > okay
02 Pulled out all USB peripherals except keyboard
03 Re-seated CPU heatsink
04 Checked to wire
05 Swapped PSU over
06 Set BIOS to default (was overclocked)
07 Turned off hyper-threading
08 Run Chkdsk /f
09 Clean boot including no startup items, disabling all norms scheduled tasks)
10 SFC no errors
There is still the option to restore to the previous version but I can’t get that far as the error message even pops up and stops that happening.

I tried the Windows Performance Recorder & Analyzer but have to admit I got a bit lost there and couldn’t see anything obvious. Are there any good resources on how to use that on boot issues?
Can anyone suggest anything else to try by that the problem will solve easily?
Thanks a lot.

Hello @Maddison

You have done so many steps but still there is a problem
you can try to update windows 1903 version.
If it also give problem download and run windows update troubleshooter tool.