Windows 10 1809 upgrade gone wrong. -" System thread exception not handled"

Okay, thinking all the dust had settled with 1809, I decided to upgrade my i7 3930k desktop to Windows 1809

It happens 2 or 3 seconds after the first set of spinning dots come up. There are no events in the event log and no minidumps so whatever is happening seems to be happening before that is loaded.

It will even occasionally cough up an “IRQL not less or equal” message and will even often happen before windows boots into recovery options

All windows drivers are up to date including GPU and other peripherals I’ve got. Everything in the device manager looks cool. MB BIOS is as up to date as I can get it.

I’ve tried the following.

  • Memtest > okay
  • Pulled out all USB peripherals except keyboard
  • Re-seated CPU heatsink
  • Checked to wire
  • Swapped PSU over
  • Set BIOS to default (was overclocked)
  • Turned off hyper-threading
  • Run Chkdsk /f
  • Clean boot including no startup items
  • SFC no errors.
  • online /cleanup-image no errors
  • All the BCDEdit fixing ideas
  • Doing a repair reinstall from the USB stick
  • CMOS Reset
  • fast startup on /off

I’m getting to think either my motherboard (Asus p9x79 pro) just can’t cope with 1809 or there’s some other motherboard driver messing things up. My guess is it’s some sort of race condition but as to what I have no clue.

Also, the motherboard has to be a bit picky as to which USB port my keyboard is in now which it wasn’t before so maybe my MB is on it’s way out.

I tried the Windows Performance Recorder & Analyzer but have to admit I got a bit lost there and couldn’t see anything obvious. Are there any good resources on how to use that on boot issues? I can pop over trace to someone if they know what they’re doing.

Running out of ideas.

Can anyone suggest else?