Windows 10 photo app not working, does not register with DCOM

This started earlier this week with one user and now I have another user reporting the same issue. Windows 10 photo app launches but then closes immediately. In the event log, I see that there are events for the Photo app that do not register with DCOM within the timeout. This is on both computers having the issue. I also get a message after the photo app crashes: The app didn’t start. I have tried upgrading the Windows 10 version to 1809, didn’t fix it. I have tried running these PowerShell commands:
get-appx package Microsoft.Windows.Photos | remove-appx package

Get-AppxPackage -allusers Microsoft.Windows.Photos | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}
Didn’t fix it.
I have logged into the Microsoft store and installed the app from there. Still the same issue. Other applications can open these pictures no problem. Just having an issue with the Photo app. This is now happening to more computers. Could this be an issue with a windows update? We use this app a lot so it is causing an issue with our current workflows.
Help is necessary for me so please guide me on the right path which can take my problem out of it.
Thank you,