Tech

Windows 10 slowing my Gigabyte fiber internet connection

Hi

In our office, we are using a fiber internet connection with 1 Gbps internet speed. We have multiple PCs with the same configuration but in one PC we are not getting the full 1 Gbps internet speed. With every other PC when I do the speed test I will get around 900 Mbps speed for this only PC I am getting around 200 Mbps speed only.

Troubleshooting Steps I performed:

  1. I performed a “Network Reset” in Windows, no change.

  2. I tried a quick install of a fresh Windows 10 on this PC (1809, same as what I am running), and got over 350, so it’s not the PC hardware.

  3. I downloaded the latest Realtek PCIe driver from Dell.com and installed on my Windows 10 and the clean install network drive.

Any suggestion will be great.
Thanks.

2 Likes

Hi @Charlie,

Sometimes windows automatically change the duplex setting to lower speed. So, before proceeding any troubleshooting steps make sure your LAN card is set to Auto Negotiation on Speed & Duplex setting as shown in the below image. If the setting is Auto Negotiation then change it to 1.0 Gbps Full Duplex and see if you are getting the full speed.

image

1 Like

Hi @Charlie,

Can I ask how you have connected your computer to the router through via wired or wireless connection? In order to get the 1 Gbps speed, you need to connect your PC through wired connection only. I am not sure if your wireless card support 1 Gbps speed.

You have mentioned you are using Windows 10 version 1809. Why don’t you upgrade your PC to Windows 10 version 1903 or Windows 10 version 1909 or Windows 10 version 2004? It might help solve your problem.

When you run the speed test always make sure there are is no background downloads like Windows updates or any software updates from the third-party applications are running because this can very the test result.